Ordering Issues

Incident Report for Redbox Systems

Postmortem

What Exactly Caused This Issue?

At 18:01 on Thursday 9 October, the customer ordering service began failing to respond due to pod scaling constraints, resulting in ordering clients being unable to load.

The issue was caused by a configuration change introduced earlier in the day as part a routine database patch and preparation for Redbox 8.0. This change limited customer services to 20 pods, below their typical scaling range. As demand increased, the restricted capacity resulted in higher load per pod, reduced responsiveness, and elevated error rates.

Impact

  • Affected Service(s): Customer Ordering
  • User Impact: Ordering clients failed to load during the affected window.
  • Duration: 18:01 – 18:52

Resolution

  • Pod limits were adjusted to restore appropriate scaling capacity.
  • Service performance improved after these changes were applied.
  • Monitoring confirmed a return to normal operating levels.
Posted Oct 10, 2025 - 09:40 BST

Resolved

This incident has been resolved.
Posted Oct 09, 2025 - 19:02 BST

Update

We are continuing to monitor for any further issues.
Posted Oct 09, 2025 - 18:57 BST

Monitoring

A fix has been implemented we are monitoring results.
Posted Oct 09, 2025 - 18:54 BST

Update

We are continiung to work on this issue.
Posted Oct 09, 2025 - 18:50 BST

Investigating

Services are currently slow and users may experience intermittent errors.
Posted Oct 09, 2025 - 18:16 BST
This incident affected: Redbox Platform (Customer Services, Management Services, Terminal Services).