Checkout - Google Pay Payments Errors

Incident Report for Redbox Systems

Resolved

This incident has been resolved.
Posted Sep 16, 2026 - 19:00 BST

Update

Google Pay issue is recovering.
Posted Sep 16, 2026 - 18:43 BST

Monitoring

Stripe is investigating an issue https://www.stripestatus.com
Posted Sep 16, 2026 - 17:25 BST
This incident affected: Payments Checkout.