Terminal Authentication
Incident Report for Redbox Systems
Resolved
This incident has been resolved.
Posted Jun 16, 2023 - 09:48 BST
Monitoring
As part of the Redbox 6.5 Release, terminal authentication has been updated to comply with the best and latest security practices. As a result, some terminals may require the re-entry of the pin.
Posted Jun 13, 2023 - 08:23 BST
This incident affected: Redbox Platform (Terminal Services).