Mail Delivery Issues

Incident Report for Redbox Systems

Resolved

This incident has been resolved.
Posted Nov 23, 2023 - 18:35 GMT

Monitoring

We are experiencing intermittent issues with email delivery due to rate limiting. This may mean some emails can't be sent, we are monitoring the situation and our limits are being increased.
Posted Nov 23, 2023 - 17:15 GMT
This incident affected: Push & Email Notifications & Campaigns.